平素より rakumo をご利用くださいまして誠にありがとうございます。
rakumo サポート担当でございます。
1月25日午後から 1月 27日 10時頃にかけて、Google 同期処理で障害が発生しておりました。
お手数でございますが、以下の内容についてご確認くださいますようお願いいたします。
障害情報詳細
発生日時
- 2024年 1月25日 午後 〜 1月 27日 10時頃
サービス
- rakumo サービス全般
内容
- Google 同期において「指定したグループだけを同期」設定を指定している場合に、高頻度でエラーが発生し処理が中断してしまう
-
エラーメッセージ内容
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グループ「〜〜〜」の情報にアクセスできなかったため、処理を中断しました。
Google 同期の設定画面で「同期するグループの設定」を確認してください。
その他、現時点で確認できている本事象に関する情報は以下の通りです。
- 中断時のエラー内容に表示されるグループは実行ごとに異なる可能性があります。
- 「同期するグループの設定」が「指定したグループだけを同期」となっている場合であっても、同期処理が正常完了する場合もあります。
- 「同期するグループの設定」が「全てのグループを同期」となっている場合には、平常通りご利用いたけます。
発生範囲
- 一部のお客様
「同期するグループの設定」が「指定したグループだけを同期」となっている場合にのみ、本事象が発生します。
本事象の発生範囲かどうかのご確認方法
Google 同期画面にアクセスして、「同期するグループの設定」の値をご確認ください。
上記のように「指定したグループだけを同期」となっている場合、本事象の影響を受ける可能性があります。
同期が必要な場合には?
「同期するグループの設定」が「指定したグループだけを同期」となっているお客様の場合
Google同期を実行いただくことは可能ですが、エラー中断となる可能性が高い状態です。※
必ず発生するという性質の事象ではなく、複数回実施いただくことで正常完了する場合もございます。
※ 1/29追記:
弊社担当部署にて状況を注視している限りでは、1月27日の 10:00 頃を境に、本事象の発生は確認されなくなっております。
同期が中断されてしまった場合には、誠に恐れ入りますが、再度、同期実行をお試しいただき、正常に完了するかどうかお試しください。
また、その際、意図せぬグループ削除が発生してしまわないよう、同期対象とするグループのメールアドレスをすべて含めた状態で同期実行操作を実施していただきますようお願いいたします。
「同期するグループの設定」が「全てのグループを同期」になっているお客様の場合
平常通り、ご利用いただけます。
原因
Google 同期で Google Workspace に存在しているグループの情報を取得する際に使用している API の実行時に、存在するグループを指定しているにもかかわらず、グループが存在しない旨のエラーが返却される場合があり、本事象が発生しておりました。
状況
【復旧済み】 2024年 1月 31日 10時30分 -------------------------------------------
すべてのお客様において、平常通り Google 同期を実行いただける状況となりましたことをお知らせいたします。
弊社担当部署にて状況を注視してまいりましたが、27日の午後以降から現在にかけて、同様の事象は発生しておりません。
また、本事象の発生原因である API のエラーに関しても、29日の 6:37 頃を境に発生しておりません。
API のエラー発生原因について Google 社からは詳細な報告等は得られませんでしたが、rakumo 側で 1月 27日に実施した修正※ により Google 同期を実行した際に API エラーの影響を受けない状況になっていること、本事象の発生原因である API のエラーが発生しなくなってから1日以上経過したことを踏まえて、本障害は解消され、平常通りご利用いただける状況に戻ったものと判断いたしました。
(※)グループが存在しない旨のエラーが返却された場合には、複数回の情報取得を試み、実施した複数回の処理全てで情報取得をできない場合のみ Google 同期処理を中断するよう修正
本事象について、長期に渡りご不便・ご迷惑をおかけいたしましたことを改めてお詫び申し上げます。
【復旧見込み】 2024年 1月 29日 11時25分 -------------------------------------------
本事象の回避策として、27日 10時頃に、Google 同期実行時のエラー処理中断の発生を緩和するリリースを行いました。
API の実行時に、グループが存在しない旨のエラーが返却された場合には、複数回の情報取得を試み、
実施した複数回の処理全てで情報取得をできない場合のみ Google 同期処理を中断するように内部処理を変更しております。
API 側の調査に関しては、現時点で Google 社からの回答がない状況ではありますが、 弊社担当部署にて状況を注視している限りでは、本日 29日の 6:37 頃を境に本事象の発生は確認できていない状況です。
引き続き状況監視・調査を進め、進捗があり次第改めてご案内を差し上げます。
できる限り早く問題解消を確認・ご案内できるように対応を進めてまいりますので、誠に恐れ入りますが、事象解消のご案内までお時間をくださいますようお願いいたします。
【発生中】 2024年 1月 26日 19時18分 -------------------------------------------
現在、Google 同期において「指定したグループのみ同期」設定を指定している場合に、高頻度でエラーが発生し処理が中断してしまう状況が発生しております。
「同期するグループの設定」が「指定したグループのみ同期」となっている場合にのみ、本事象が発生します。
対象のお客様には、ご不便ならびにご迷惑をおかけし、誠に申し訳ございません。
Google 同期で Google Workspace に存在しているグループの情報を取得する際に使用している API の実行時に、存在するグループを指定しているにもかかわらず、偶発的に グループが存在しない旨のエラーが返却される場合があり、本事象が発生しております。
上記状況から、本事象の発生原因について、現在 Google 社へ調査を依頼しております。
進捗があり次第、追加のご案内を掲載いたします。
誠に恐れ入りますが、お時間をくださいますようお願いいたします。
お客様にはご迷惑ならびにご不便をおかけいたしまして、誠に申し訳ございません。
本件につきまして、ご不明な点がありましたら、お問い合わせフォームよりお知らせくださいませ。
どうかよろしくお願い申し上げます。
2024年 1月 26日
rakumo サポート担当