rakumo ワークフローrakumo ワークフロー

ケイヒ・ワークフロー連携利用時の精算書に、承認済みの捺印欄が表示されない事象が発生

平素よりrakumoをご利用くださいまして誠にありがとうございます。
rakumoサポートでございます。

9月 27日 〜 9月 30日にかけて、rakumo ケイヒ・ワークフロー連携機能利用時に、下記の事象が発生しておりました。
本事象により、お客様に大変なご迷惑をおかけしましたことを深くお詫び申し上げます。

詳細については、お手数でございますが、以下をご確認くださいますようお願いいたします。

障害情報詳細

サービス

rakumo ワークフロー

発生日時

2022年 9月 27日 14時頃 〜 9月 30日 12時頃

内容

ケイヒから申請しワークフローで承認された経費精算書 PDF をワークフローユーザー画面から参照した場合に、捺印欄が空欄になる

発生範囲

rakumo ケイヒの「ワークフロー設定」機能を利用して、rakumo ケイヒから申請し、rakumo ワークフローで承認されたすべての経費精算書

原因

9月27日に、ワークフローの表示に使用する技術基盤の変更(機能追加を伴わないアップデート)を実施いたしました。
リリース前の技術基盤の変更に伴う影響範囲の確認作業に不足があり、本事象が発生いたしました。

回避策

修正完了までの回避策として、以下のいずれかの方法にて、捺印欄に承認情報が表示された状態の精算書 PDF をご取得ください。

  • A. 申請者(ユーザー)本人の場合:ケイヒ画面から精算書を取得する
  • ケイヒ画面にアクセスして、当該精算書右上の「印刷する」をクリックします。
    その後「印刷する」または「Google Drive に保存する」をクリックすると、捺印欄に承認情報が表示された状態で精算書PDFを参照・保存することができます。

  • B. 管理者・承認者の場合:精算書状況により異なります。
  • はじめに、精算書に領収書が添付されているかどうかをご確認ください。

    【B-1】精算書に領収書が添付されている場合:領収書ダイアログを経由して精算書を取得する
    当該申請の「領収書を確認する」リンクから一度領収書ダイアログを開いて、ダイアログ内の「精算書PDFを開く」をクリックすることで、捺印欄に承認情報が表示された状態で精算書 PDF をダウンロードできます。

    【B-2】精算書に領収書が添付されていない場合:ワークフロー管理画面から申請書詳細を開いて、精算書PDFを取得する
    ワークフロー管理画面 > 申請書の管理 から、当該申請書の詳細画面を開きます。
    申請内容の「経費精算書」項目のリンクをクリックして、精算書 PDF を表示します。

    もしワークフロー管理者とケイヒ管理者の権限を合わせて持っている場合は、
    ケイヒ管理画面 > 精算書の一覧 から当該精算書を検索して精算書の詳細を表示した際、上部に表示される「■WF申請書」に続くリンクから、ワークフロー管理画面の当該申請書の詳細画面へ直接アクセスすることも可能です。

  • C. 申請者・承認者共通:スマートフォン・タブレット端末からワークフロー画面にアクセスして取得する
  • スマートフォン・タブレット端末からアクセスすることで、捺印欄に承認情報が表示された状態で精算書 PDF の参照・ダウンロードが可能です。

    ▼ ワークフローユーザー画面 URL
    https://a-rakumo.appspot.com/workflow/

状況

【復旧済み】2022年 9月 30日 13時10分 --------------------------------------------

本件につきまして、本日 12時頃に修正対応が完了いたしましたことをご報告いたします。

これにより、現在は、平常通り捺印欄で承認済みステップの情報をご確認いただける状態に復旧しております。
問題解消まで、お時間を頂戴いたしましたことを深くお詫び申し上げます。

今後技術基盤の変更を実施する際は、より慎重に影響範囲の抽出・確認を実施し、今回のような事象が生じないよう努めてまいります。
改めまして、本事象により、お客様に大変なご迷惑をおかけしましたことを深くお詫び申し上げます。

【発生中】2022年 9月 28日 15時00分 --------------------------------------------

現在、担当部署にて事象について調査・修正を実施しております。
進捗を改めてご連絡をいたしますので、今しばらくお時間をくださいますようお願いいたします。

お客様にはご迷惑ならびにご不便をおかけいたしまして、誠に申し訳ございません。

本件につきまして、ご不明な点がありましたら、お問い合わせフォームよりお知らせくださいませ。

どうぞよろしくお願い申し上げます。

2022年9月28日
rakumo サポート担当