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Salesforce から Google カレンダーへ予定を同期できない事象が発生

平素よりrakumoをご利用くださいまして誠にありがとうございます。
rakumoサポートでございます。

2月 14日 から 2月 15日にかけて、rakumo Sync で予定が同期されない状況が発生しておりました。
現在は復旧し、平常通りご利用いただける状況となっておりますことを併せてご報告いたします。

詳細については、お手数でございますが、下記をご確認くださいますようお願いいたします。

詳細

対象の時間帯

2024年 2月 14日 18時17分頃 〜 2月 15日 17時15分頃

サービス

rakumo Sync

内容

【対象の時間帯】において、Salesforce から Google カレンダーへ、予定が同期されない
※ 上記時間帯においても、Google カレンダーから Salesforce への予定の同期は正常に行われておりました。

原因

rakumo Sync で使用している SSL 証明書の更新にあたって、1)当初弊社が用意した更新用の SSL 証明書のルート証明書が Salesforce の信頼する証明書リスト *に含まれていなかったこと、2)弊社内の SSL 証明書更新作業の手順や事前検証・更新後の検証の手順に不備があったこと により、本事象が発生いたしました。

今回、弊社が更新用の SSL 証明書を取得する直前に、取得元企業が SSL 証明書のルート証明書を新しいものに更新しておりました。
また、ルート証明書の更新直後であったことから、弊社が 2月 14日にSSL証明書の更新作業を実施した時点では、当該企業が発行する SSL 証明書のルート証明書が Salesforce の信頼する証明書リストに含まれない状況となっておりました。
この影響を受けて、Salesforce から rakumo Sync への通信を実施することができない状況となりました。

また、弊社内の SSL 証明書更新作業の手順や事前検証・更新後の検証手順の不備により、2月 14日の SSL 証明書の更新時に上記状況を検知することができず、本事象が発生しました。

* Salesforce から 外部サーバーへ SSL 通信でデータを送信する際、送信先サーバーでは Salesforce の信頼する証明書リストに含まれるルート認証局の証明書の採用が求められます。

再発防止策

SSL 証明書の更新手順 および 更新後の確認事項の見直し・手順書の更新を実施いたしました。

状況

【解消済み】2024年 4月18日 10時40分 --------------------------------------------

原因・再発防止策を追記いたしました。
今回の事象発生原因であった SSL証明書の更新作業については、は 2月 21日に再実施し、正常完了しております。
あわせて、SSL 証明書の更新後も平常通りご利用いただける状態であることを確認済みですのでご安心ください。

今後このようなことが発生しないよう、再発防止に努めてまいります。
改めまして、今回の事象についてご不便・ご迷惑をおかけいたしましたことを深くお詫び申し上げます。

【解消済み】2024年 2月15日 20時04分 --------------------------------------------

本件について、ご不便・ご迷惑をおかけし誠に申し訳ございません。
弊社にて暫定対応を実施し、現在は平常通りご利用いただける状況となっております。

弊社担当部署にて、対象の時間帯の予定の同期状況を確認したところ、
2024年 2月 14日 18時17分頃 〜 2月15日 16時02分頃、 2月15日 17時00分頃 〜 17時15分頃 について、 Google カレンダーから Salesforce への同期は正常に行われておりましたが、
Salesforce から Google カレンダーへの同期ログが存在しない状態となっておりました。

誠に恐れ入りますが、 上記時間帯において Salesforce から予定操作を行なったお心当たりがある場合は、Google カレンダーをご確認いただき、予定の同期状況についてご確認くださいますでしょうか。
もし同期されていない予定が存在する場合には、大変お手数でございますが、予定を更新してくださいますようお願いいたします。
お手数をおかけいたしまして、誠に申し訳ございません。

なお、2月 15日 17時 15分頃以降については、平常通り、双方向で同期が行われていることを確認しておりますのでご安心ください。

お客様にはご迷惑ならびにご不便をおかけいたしまして、誠に申し訳ございません。
本事象の詳しい発生原因については、現在調査を進めております。
調査に進捗があり次第、改めてご報告いたしますので、誠に恐れ入りますが、お時間をくださいますようお願いいたします。

本件につきまして、ご不明な点がありましたら、お問い合わせフォームよりお知らせくださいませ。

どうかよろしくお願い申し上げます。

2024年 2月 15日
rakumo サポート担当